CallHub Voice services impacted
Incident Report for CallHub
Resolved
Issues at the telecom carrier have been resolved. CallHub Service is working well. Please let us know if you face any issues at support@callhub.io. Thanks.
Posted 15 days ago. Apr 10, 2019 - 08:19 PDT
Investigating
CallHub Voice services are intermittently failing across all geographies, due to issues with our telecom carriers. We're working with them on resolving these issues. We will keep you posted on the updates. If you have any queries please do send them to support@callhub.io.
Posted 15 days ago. Apr 10, 2019 - 07:28 PDT
This incident affected: Phone Calls.