Text Messages delivered outside of scheduled campaign hours
Incident Report for CallHub
Postmortem

Problem

On Nov 10, 2019 several contacts who were part of a texting campaign on CallHub received text messages outside of normal operational hours. Campaigns that were scheduled to stop at specific times continued to run outside of that schedule.

Root cause
Send rates for text messages were configured at a higher rate than supported by our carrier provider. The carrier provider in turn queued text messages that exceeded the send limit and delivered them outside of campaign hours scheduled within CallHub.

Solution
We’ve updated the system to ensure that our send rate for texts and the carrier send rates stay in sync. This adheres the CallHub platform and our carriers to the same sending schedule.

Posted Nov 11, 2019 - 09:24 PST

Resolved
On Nov 10, 2019 several contacts who were part of a texting campaign on CallHub received text messages outside of normal operational hours. Campaigns that were scheduled to stop at specific times continued to run outside of that schedule.
Posted Nov 10, 2019 - 13:00 PST