We encounter sporadic Call Centre problems while making calls in the web browser. This is due to an ongoing issue with one of our telecom carriers.
Incident Report for CallHub
Resolved
The calling service has been fully restored and is now operational.
Posted May 18, 2023 - 22:15 PDT
Monitoring
A fix has been implemented, and the browser call is returning to normal. However, we are still monitoring the system.
Posted May 18, 2023 - 18:58 PDT
Investigating
We are actively investigating the problem and collaborating with relevant teams to resolve it quickly.
Posted May 18, 2023 - 17:13 PDT
This incident affected: Browser Calls.