Due to a current service interruption at one of our third-party services, CallHub calling services are affected for all customers.
Incident Report for CallHub
Resolved
This incident has been resolved.
Posted Sep 05, 2023 - 23:03 PDT
Monitoring
The concerned team has implemented a fix and is monitoring the impact. The calling service should be back to normal for you. Still, we are monitoring the system.
Posted Sep 05, 2023 - 16:11 PDT
Identified
We are working with the concerned team and will keep you posted here.
Posted Sep 05, 2023 - 15:57 PDT
This incident affected: Phone Calls and Browser Calls.