Due to a current service interruption at one of our third-party services, CallHub calling services are affected for all customers.
Incident Report for CallHub
Resolved
The concerned team has implemented a fix and the calling service should be back to normal for you. This incident has been resolved.
Posted Sep 06, 2023 - 14:33 PDT
Update
We are still working with the concerned teams on a fix. Please stay tuned.
Posted Sep 06, 2023 - 11:23 PDT
Identified
We are working with the concerned team and will keep you posted here. A fix is being implemented. Stay tuned.
Posted Sep 06, 2023 - 10:00 PDT
This incident affected: Phone Calls and Browser Calls.