CallHub Voice services impacted
Incident Report for CallHub
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 24, 2019 - 05:11 PST
Update
Our telecom carriers are back up. Our preliminary tests are running fine. We are currently monitoring for stability.
Posted 5 months ago. Jan 24, 2019 - 05:10 PST
Update
We are continuing to investigate this issue.
Posted 5 months ago. Jan 24, 2019 - 04:54 PST
Investigating
CallHub Voice services impacted across all geographies, due to issues with our telecom carriers. We're working with them on resolving these issues. We will keep you posted on the updates. If you have any queries please do send them to support@callhub.io.
Posted 5 months ago. Jan 24, 2019 - 04:52 PST
This incident affected: Phone Calls and Browser Calls.