Elevated load on CallHub servers
Incident Report for CallHub
Resolved
Sorry for the trouble you faced. CallHub services are back to normal. We're monitoring the servers from our end, will keep you informed on any issues we encounter.
Posted 9 months ago. Feb 14, 2018 - 14:38 PST
Investigating
We're experience high load on our servers because of which the service is not operational intermittently. We're looking into this issue and will keep you updated on the progress.
Posted 9 months ago. Feb 14, 2018 - 11:53 PST