Scheduled Maintenance on March 4, 12 am - 2 am UTC
Incident Report for CallHub
Resolved
Thank you for your patience, the scheduled maintenance is now successfully complete. Should you see any issues please contact us on support@callhub.io. Thanks.
Posted 5 months ago. Mar 03, 2018 - 17:46 PST
Investigating
As informed earlier, we will be performing database maintenance to improve stability of our platform. While we are making these updates, your service will be interrupted. Request you to keep your campaigns paused during the maintenance period to avoid any disruptions.
Posted 5 months ago. Mar 03, 2018 - 16:02 PST