Call Center calls are not operational
Incident Report for CallHub
Resolved
Service is up. Marking this incident as resolved.
Posted May 10, 2017 - 03:44 PDT
Investigating
We are seeing issues with our Call Center product. CallHub Team is looking at it, we will update you once the service is back.
Posted May 10, 2017 - 02:45 PDT
This incident affected: Browser Calls.