CallHub Service is down
Incident Report for CallHub
Resolved
This incident has been resolved.
Posted 10 months ago. Nov 24, 2017 - 08:57 PST
Monitoring
All services are back up. We are monitoring the servers for any trouble.
Posted 10 months ago. Nov 24, 2017 - 08:47 PST
Investigating
CallHub database servers are down. Our team is bringing up a new DB server.
Posted 10 months ago. Nov 24, 2017 - 08:35 PST