High failure rates in Call Center Campaigns
Incident Report for CallHub
Resolved
This incident has been resolved.
Posted 10 days ago. Nov 05, 2018 - 21:54 PST
Investigating
Systems are back to normal now, users can continue using call center campaigns.
Posted 10 days ago. Nov 05, 2018 - 14:55 PST
This incident affected: Phone Calls.