Call Center calls are not operational
Incident Report for CallHub
Resolved
Thanks for being patient. CallHub service is back up. Please open up a support ticket if any errors reappear.
Posted May 11, 2017 - 06:54 PDT
Investigating
We are seeing issues with our Call Center product. CallHub Team is looking at it, we will update you once the service is back.
Posted May 11, 2017 - 06:45 PDT
This incident affected: Browser Calls.