CallHub services not operational
Incident Report for CallHub
Resolved
We have resolved the issues in our system, we continue to monitor our servers. Thanks for your patience and sorry for the inconvenience caused.
Posted 9 days ago. May 12, 2018 - 11:34 PDT
Identified
Some of CallHub services like Call Center and SMS Products are online. Voice Broadcast campaigns are still having issues, we're working on them
Posted 9 days ago. May 12, 2018 - 10:10 PDT
Investigating
We're having issues with our servers, our engineering team is looking at the issues. We will keep you posted when the incident is resolved.
Posted 9 days ago. May 12, 2018 - 08:46 PDT
This incident affected: Main Dashboard, Phone Calls, SMS Messages, Analytics, Browser Calls, and Imports.