CallHub is facing service disruption with voice calls broadcast for US / Canada numbers
Incident Report for CallHub
Resolved
This incident has been fixed and voice calls are working fine. It was a caching issue on one of our servers. We are considering it resolved now.

Sorry for the inconvenience caused to you.
Posted Apr 11, 2024 - 13:56 PDT
Monitoring
We have identified the problem and placed a fix to resolve it. Voice calls should work for all CallHub customers. We will share more insights later.

We are still monitoring the voice services at our end.
Posted Apr 11, 2024 - 12:58 PDT
Investigating
We are currently investigating the matter with the concerned team and will keep you posted on it.

Sorry for the inconvenience.
Posted Apr 11, 2024 - 12:37 PDT
This incident affected: Phone Calls.